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CAD-CAM-CAE Example 
 

 

example title: Create a mechanical drawing in CAD system 

example number: ÓE-A13 

example level: basic - medium - advanced 

CAx system: CATIA V5 

Related material part with TÁMOP  CAD 

Job Description: Create a mechanical drawing from an assembly 

model in CATIA v5 system.  

 

1. The task 

 

Create a mechanical drawing from an assembly model in CATIA v5 system! 
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2.   The solution steps 

 

Select File > Open..., or click Open  in the Standard toolbar. The File Selection dialog box 

appears. Select the sample assembly file from the sample directory and click Open.  

 

From the menu bar, select Start > Mechanical Design. Select the Drafting workbench.  

The New Drawing Creation dialog box appears with information on views that can possibly 

be created, as well as information on the drawing standards.  

Select the Empty sheet from the New Drawing Creation dialog box. Click the Modify button. 

Select the A2 ISO in the Sheet Style field on the New Drawing tab. Click OK. 

 

  
 

 

In the Generative Drafting workbench, the view name, scaling factor and view frame are set 

by default in views. Throughout this section of the Getting Started, we decided not to display 

view names and scaling factors. To deactivate them, go to Tools > Options > Mechanical 

Design > Drafting, click on the Layout tab and clear the View name and Scaling factor check 

boxes. 

You see a white empty white sheet and the specification tree on left side of screen. 

If you do not want to have the specification tree displayed, press the F3 key. 

 

Select Edit > Background.   

 

 
 

Click Frame and Title Block   in the Drawing toolbar or select Insert > Drawing > 

Frame and Title Block. The Manage Frame and Title Block dialog box is displayed. 
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Choose a macro from the Style of title block drop-down list. For the purpose of this exercise, 

choose Drawing Titleblock Sample 1. A preview of the frame and title block is displayed in 

the dialog box. Indicate the action you want to perform in the Action list. Select the Create 

from the list. Click OK in the Manage Frame and Title Block dialog box. Wait while the 

frame and title block are being created. 

 

  
 

 

 Select a text in the title Block and click twice. Now you can change the text with text editor 

tab. 

 

 
 

Use Edit > Working Views when you need to work on views.  

 When adding sheets, if you want the frame and title block to appear in newly created sheets, 

go to Tools > Options > Mechanical Design > Drafting > Layout tab. Select the Copy 

background view check box and the First sheet option. This will insert the frame and title 

block from the sheet you previously created on the current drawing. 

 

When the Frame and Title Block icon  is activated, you cannot edit the views. 

Select Edit > Working Views from the menu bar to switch back to the working views. 

 

Click Front View  in the Views toolbar (Projections sub-toolbar).  Now, in the part 

window, select the desired planar surface of the 3D part. 
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Blue arrows appear. Note that you can redefine the projection plane using the blue arrows at 

any time before the view generation: to the bottom, the left, the right, the top, or rotated using 

a given snapping or according to an edited rotation angle.  

Click in the drawing to generate the view. 

 

 

  
 

 

Double-click Projection View  in the Views toolbar (Projections sub-toolbar). 

 As you move the cursor, a previewed projection view in a green frame appears on the sheet. 

Define the projection view position by positioning the cursor at the desired view location, for 

example the right view position. 

Click inside the green frame to generate the right side view. 

 

 

   
 

Define the top view position. Click inside the sheet to generate the view. 

Click Projection View  to end the projection view creation. 

 

  
All views have a colour frame. When the frame is red  the view is Activated. 

If we want modify someone in the view then we want active this view.  

Right-click the view and select Activate View. 
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Click Clipping View Profile  in the Views toolbar (Clippings sub-toolbar), to create a 

clipping view using a sketched profile as callout. Select the required points for sketching a 

polygon. Close the polygon, or double-click to end its creation.  The view and the associated 

profile result as shown here. 

 

   
  

 

 

 

Activate the Front view and then click Breakout View  in the Views toolbar (Break View 

sub-toolbar). Click the first point of the breakout profile. 

Click as many points as desired for creating the profile. If needed, double-click to end the 

profile creation and close this profile automatically or click on the profile first point to close 

and end the profile creation.  
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Check the Animate option to visualize the 3D part in accordance with the position of the 

cursor on a generated view. In the CATDrawing document, place the cursor over the center 

line that will be used as an extremity plane, as shown below. 

Click OK in the 3D Viewer window. The breakout view is created. 

 

 

  
 

Repeat this method and we use three times the Breakout View command. See below. 

 

     
 

Once the area fill is created, you can modify the shape of an area fill. 

Select the pattern be modified. For the purpose of our scenario, select the hatching pattern in 

the Section view. Select Edit> Properties. You can also right-click the pattern and then select 

Properties from the displayed contextual menu. 

In the Properties dialog box that appears, click the Pattern tab. 

 

1. To define your own pattern, choose a pattern type from the Type drop-down list:  

o Hatching  

o Dotting  

o Coloring  

o Image  

If you want to choose from the various patterns available, you can also click the [...] 

button. This will display the Pattern Chooser, from which you can make your 

selection.  

2. Select your options as required.  
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 o The options available in the dialog box depend on the type of pattern you selected, as well 

as on the standard used by the drawing.  

o When editing the properties of a pattern associated with a part material, the software offers 

its own selection of patterns, and not the patterns defined in the standard.  

Hatching 

o Number of hatchings: Defines the number of different hatchings to use in this pattern. A tab 

will be created for each hatching, to let you define each one individually.  

This option is unavailable with the current drawing standard.  

o Angle: For each hatching this pattern, specifies the angle value in degrees.  

o Pitch: For each hatching in this pattern, specifies the pitch in millimeters.  

o Offset: For each hatching in this pattern, specifies the offset in millimeters.  

o Color: For each hatching in this pattern, specifies the color.  

This option is unavailable with the current drawing standard.  

o Linetype: For each hatching in this pattern, specifies the linetype.  

This option is unavailable with the current drawing standard.  

o Thickness: For each hatching in this pattern, specifies the linetype thickness.  

This option is unavailable with the current drawing standard.  

o Preview: Lets you preview the resulting hatching pattern.  

 

The Color, Linetype and Thickness options can be modified, provided the EditAvailability 

parameter is set to Yes under the Pattern node in the Standards editor.. 

 
 

  

 

Dotting 

o Pitch: Specifies the dotting pitch in millimeters.  

o Color: Specifies the dotting color.  

o Zigzag: Specifies whether dotting should zigzag.  
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o Preview: Lets you preview the resulting dotting pattern.  

Coloring 

o Color: Specifies the color.  

o Preview: Lets you preview the resulting coloring pattern.  

Image 

o Browse button: Lets you select the image to use for this pattern.  

This option is unavailable with the current drawing standard. You can only use the images 

defined by the administrator. These images are available from the pattern chooser (click the 

[...] button).  

o Angle: Specifies the angle value in degrees.  

o Scale: Specifies the scale.  

o Preview: Lets you preview the original image (not the result after modifying the angle and 

scale).  

6. Click OK to validate and exit. 

 

The area fill profile will therefore consist of both sketched and generative elements. 

You do not need to activate the view in which you are going to create an area fill. 

Click Area Fill Creation  in the Dress-Up toolbar. 

The Tools Palette toolbar appears. 

 

 

Click Automatic Detection  and then click inside the area for which you just defined the 

profile, under the line which represents the fillet edge. 

The software automatically detects the area to fill based on where you clicked and fills this 

area with the selected pattern. The Tools Palette toolbar disappears. 

 

  
 

1. Right-click the front view and select Edit > Properties.  

2. Click the View tab. You can notice that a number of options are disabled, as they apply 

to generative views only.  

3. Choose your options.  
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See the picture below. This shows the main settings  

 

  

 

Visualization and behaviour 

 
  Display View Frame: shows/hides the view frame,  

 Lock View: locks the view so that it cannot be modified anymore.  

 Visual Clipping: lets you reframe a view so as to display only part of it. Refer to Reframing a View for more 

information.  

 
Scale and Orientation  

 
  Angle: defines the angle between the view and the sheet,  

 Scale: defines the scale of the view.  

 =: displays the decimal value with respect to the fraction. This field is read-only.  

 
Dress-up 

Specifies the dress-up elements that should be displayed in the view: 

 Hidden Lines: generates hidden lines.  

 Center Line: generates center lines.  

 3D Spec: specifies whether, in an assembly, the properties assigned to given parts (also called components) will be 

applied in the view.  
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The following 3D specifications may be defined for components in the Product Structure workbench:  

 The component will, or will not, be cut when projected in section views (Do not cut in section views).  

 The component will, or will not, be projected in views (Do not use when projecting).  

 The component will, or will not, be represented with hidden lines (Represented with hidden lines).  

  

 3D Colors: specifies that the colors of a part should be automatically generated onto the views.  

 Axis: generates axis lines.  

 Thread: generates threads. 

 

Fillets: generates fillets. You can choose to view Boundaries, Symbolic, Approximated 

Original Edges, Projected Original Edges:  

  

  Boundaries 

Thin lines, representing the mathematical limits of the fillets.  

 

Boundaries will not be projected if they correspond to two faces which are continuous in 

curvature. They will be projected only if they correspond to a smooth edge which is situated 

between two faces whose curvature radii vary.  

 

This mode will be used automatically to represent a connection between two faces which are 

not joined by a fillet, no matter what option you select. 

   

  Symbolic  

Original edges, projected in a direction that is normal to each corresponding surface. 

   

  Approximated Original Edges 

Original edges, at the intersection of the two surfaces joined by the fillet. 

   

  Projected Original Edges  

Original edges, projected on fillet surfaces in the direction of the view projection.  

This projection mode is equivalent to the CATIA V4 fillet projection mode. 

 

 

Click OK to validate and exit the Properties dialog box. 
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Double-click the view from which you want to create the section view, to activate it. In this 

particular case, double-click the front view.  

The first point of the cutting profile is automatically created on the view. The section plane 

appears and moves dynamically on the 3D sub-assembly while you define the profile on the 

drawing. 

In the drawing window, click Offset Section View  in the Views toolbar (Sections sub-

toolbar).  Select the axis line in the left view. 

Select the line in the front view. See below. The first point of the cutting profile is 

automatically created on the view. The section plane appears and moves dynamically on the  

 

 

  
 

3D sub-assembly while you define the profile on the drawing. Double-click the last point of 

the cutting profile to end its creation. Define the section view position using the cursor. 

Click to generate the view. A progress bar appears while the view is being created. 

 

  
 

Create the rest sections with Offset Section View command. 
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Double-click the A-A view to activate it..Create a section from this view also. 

   
 

 

Creating Dimensions 

 

 

First Create the Length dimensions. 

Click the Dimensions icon  on the Dimensioning toolbar. 
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Click a line in the view. Click another line in the view. The dimension type is automatically 

defined according to the selected elements (  or  in the Tools Palette). 

At this step, the options in the Tools Palette (         ) allow you to 

position the dimension using one of the following modes: Projected or Forced modes. These 

options are also available in the contextual menu. 

This toolbar is situated at the bottom right of screen. If you cannot see it properly, just undock 

it. Click in the drawing window to validate the dimension creation. 

  

 

  
 

 

Create the Diameter dimensions. Click the Dimensions icon. 

Click a circle in the view.  Click the Force Dimension on element  icon from the Tools 

Palette. Right-click to access the contextual menu and select 1 symbol.  

The dimension becomes a one-symbol dimension. During the dimension creation step, you 

can switch between one-symbol or two-symbols dimension by selecting or deselecting 1 

symbol in the contextual menu.  

Once the dimension has been created, you must use the Properties menu to specify whether 

you want to use one or two symbols. Right-click the dimension and in the contextual menu, 

choose Properties. Click the Dimension Line tab and then select Symbol 2 to display two-

symbols dimension, or clear this check box to display one-symbol dimension. Click the Right 

mouse button and then select Diameter Center from the displayed contextual menu. 
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Creating Half-Dimensions 

 

You can create half-dimensions on distance, angle, diameter cylinders, radius cylinders made 

out of two selections, diameter edges and diameter tangents. You cannot create half-

dimensions on cumulated dimensions. 

Half-dimensions are useful in the case of revolved features or elements using a plane 

symmetry, as they let you create the dimensions only on half the geometry. Click Dimensions 

in the Dimensioning toolbar. 

Click a first element in the view. For example, an edge. If needed, click a second element in 

the view. For example, another edge. Right-click the dimension and select Half Dimension. 

The half-dimension appears. Only one extension line is displayed. The dimension line is 

shortened with specific overrun, gap and length. The value is not centered on the dimension 

line. The attributes mentioned in Dimension parameters drive the dimension graphic display. 

 

   
 

 

Access and edit dimension value properties if it need. Select a dimension. Click the Right 

mouse button and then select Properties from the displayed contextual menu. If needed, 

modify the available options. Click OK to validate and exit the dialog box. 

. 
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Creating a Text With a Leader 

 

Click the Text With Leader icon  from the Annotations toolbar (Texts sub-toolbar). 

 

Click the point on the element you want the leader to begin (arrow end). 

A red frame appears. Click in the free space to define a location for the text. The Text Editor 

dialog box is displayed. Enter the text in the Text Editor dialog box or directly on the 

drawing. If needed, re-position or modify the text. To end the text creation, click again in free 

space or select a command icon. 

 

  
 

Creating an Associated Text 

 

Click the Text icon  in the Annotations toolbar.  
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Select the element to which you want to associate a text. Enter the text to be created in the 

Text Editor dialog box or directly on the drawing. Click in the free space or click the Select 

icon  to end the text creation.  

 

 

  
 


